# CVE-2008-2302: Django Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML into the Django administration login form via a crafted URI, potentially compromising admin sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 May 2008
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-2302, GHSA-54qj-48vx-cr9f, PYSEC-2008-1

## What is CVE-2008-2302?

CVE-2008-2302 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-2302?

7 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.1 |
| `django` | PyPI | From 0.91 | 0.91.2 |
| `django` | PyPI | From 0.95 | 0.95.3 |
| `django` | PyPI | From 0.96 | 0.96.2 |
| `Django` | PyPI | From 0.91 | 0.91.2 |
| `Django` | PyPI | From 0.95 | 0.95.3 |
| `Django` | PyPI | From 0.96 | 0.96.2 |

Products: Django Project Django.

## How do I fix CVE-2008-2302?

Upgrade django to a fixed version for your release line: 1.1, 0.91.2, 0.95.3 or 0.96.2.

## Is CVE-2008-2302 being exploited?

There is no known exploitation of CVE-2008-2302 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-0404](https://insights.sbomify.com/CVE-2007-0404/): Django Arbitrary Code Execution (high 7.5)
- [CVE-2007-5828](https://insights.sbomify.com/CVE-2007-5828/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2007-0405](https://insights.sbomify.com/CVE-2007-0405/): Django Improper Access Control (medium 6.5)
- [CVE-2009-2659](https://insights.sbomify.com/CVE-2009-2659/): Django Admin Media Handler Vulnerable to Directory Traversal (medium 5.0)
- [CVE-2007-5712](https://insights.sbomify.com/CVE-2007-5712/): Django vulnerable to Denial of Service via i18n middleware component (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-2302 and fix it if it is affected.

What it is: CVE-2008-2302 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-2302 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.1
- django (PyPI): affected from 0.91; fixed in 0.91.2
- django (PyPI): affected from 0.95; fixed in 0.95.3
- django (PyPI): affected from 0.96; fixed in 0.96.2
- Django (PyPI): affected from 0.91; fixed in 0.91.2
- Django (PyPI): affected from 0.95; fixed in 0.95.3
- Django (PyPI): affected from 0.96; fixed in 0.96.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-2302/ (Markdown: https://insights.sbomify.com/CVE-2008-2302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-2302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-2302
- OSV: https://osv.dev/vulnerability/CVE-2008-2302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-2302/
Summaries are generated and may contain mistakes; the official description above is the record.
