CVE-2008-2370 Apache Tomcat Path Traversal Vulnerability
Remote attackers can read arbitrary files via directory traversal in Apache Tomcat when RequestDispatcher is used, requiring specific configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2008-2370?
CVE-2008-2370 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 4 Aug 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when a RequestDispatcher is used, performs path normalization before removing the query string from the URI, which allows remote attackers to conduct directory traversal attacks and read arbitrary files via a .. (dot dot) in a request parameter.
Weakness: CWE-22
Which versions are affected by CVE-2008-2370?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.38 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.38 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.27 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.27 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.18 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.18 |
Products include Apache Tomcat.
How do I fix CVE-2008-2370?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.38, 5.5.27 or 6.0.18.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2008-2370 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-2370 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-m8h8-6rvg-f4mg.