{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-2375 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2008-2375 is a high-severity denial of service vulnerability in n/a, published on 9 Jul 2008. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2008-2375 and fix it if it is affected.\n\nWhat it is: CVE-2008-2375 is a high-severity denial of service vulnerability in n/a, published on 9 Jul 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2008-2375 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-2375/ (Markdown: https://insights.sbomify.com/CVE-2008-2375/index.md)","id":"CVE-2008-2375","markdown":"https://insights.sbomify.com/CVE-2008-2375/index.md","name":"CVE-2008-2375","record":{"aliases":["GHSA-8hxj-gw9h-vgfv","RHSA-2008:0579","RHSA-2008:0680"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"vsftpd FTP server","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory consumption in vsftpd when PAM is enabled, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"vsftpd","vendor":"redhat"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"Memory leak in a certain Red Hat deployment of vsftpd before 2.0.5 on Red Hat Enterprise Linux (RHEL) 3 and 4, when PAM is used, allows remote attackers to cause a denial of service (memory consumption) via a large number of invalid authentication attempts within the same session, a different vulnerability than CVE-2007-5962.","ecosystems":["Red Hat:enterprise_linux:3::as","Red Hat:enterprise_linux:3::es","Red Hat:enterprise_linux:4::as","Red Hat:enterprise_linux:4::es"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2008-2375","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2008"},"n_packages":8,"n_references":15,"next":{"headline":"Integer overflow in n/a","id":"CVE-2008-2376"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:3::as","fixed":["0:1.2.1-3E.16"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/redhat/vsftpd","source":"RHSA-2008:0579"},{"ecosystem":"Red Hat:enterprise_linux:3::as","fixed":["0:1.2.1-3E.16"],"introduced":["0"],"last_affected":[],"package":"vsftpd-debuginfo","purl":"pkg:rpm/redhat/vsftpd-debuginfo","source":"RHSA-2008:0579"},{"ecosystem":"Red Hat:enterprise_linux:3::es","fixed":["0:1.2.1-3E.16"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/redhat/vsftpd","source":"RHSA-2008:0579"},{"ecosystem":"Red Hat:enterprise_linux:3::es","fixed":["0:1.2.1-3E.16"],"introduced":["0"],"last_affected":[],"package":"vsftpd-debuginfo","purl":"pkg:rpm/redhat/vsftpd-debuginfo","source":"RHSA-2008:0579"},{"ecosystem":"Red Hat:enterprise_linux:4::as","fixed":["0:2.0.1-6.el4"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/redhat/vsftpd","source":"RHSA-2008:0680"},{"ecosystem":"Red Hat:enterprise_linux:4::as","fixed":["0:2.0.1-6.el4"],"introduced":["0"],"last_affected":[],"package":"vsftpd-debuginfo","purl":"pkg:rpm/redhat/vsftpd-debuginfo","source":"RHSA-2008:0680"},{"ecosystem":"Red Hat:enterprise_linux:4::es","fixed":["0:2.0.1-6.el4"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/redhat/vsftpd","source":"RHSA-2008:0680"},{"ecosystem":"Red Hat:enterprise_linux:4::es","fixed":["0:2.0.1-6.el4"],"introduced":["0"],"last_affected":[],"package":"vsftpd-debuginfo","purl":"pkg:rpm/redhat/vsftpd-debuginfo","source":"RHSA-2008:0680"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2008-2374"},"products":["n/a"],"published":"2008-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory consumption in vsftpd when PAM is enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2008-2375/"}