# CVE-2008-2717: TYPO3 Unrestricted File Upload vulnerability

> Remote attackers can bypass file upload restrictions to upload malicious configuration files, potentially leading to code execution.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-f35p-hcwf-9f9f

## What is CVE-2008-2717?

CVE-2008-2717 is a medium-severity vulnerability in Typo3 Typo3, published on 16 Jun 2008. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TYPO3 4.0.x before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.2.1, uses an insufficiently restrictive default fileDenyPattern for Apache, which allows remote attackers to bypass security restrictions and upload configuration files such as .htaccess, or conduct file upload attacks using multiple extensions.

Weakness: CWE-264

## Which versions are affected by CVE-2008-2717?

6 open source packages ship an affected version, including typo3/cms-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 4.0.0 | 4.0.9 |
| `typo3/cms-core` | Packagist | From 4.0.0 | 4.0.9 |
| `typo3/cms-core` | Packagist | From 4.1.0 | 4.1.7 |
| `typo3/cms-core` | Packagist | From 4.1.0 | 4.1.7 |
| `typo3/cms-core` | Packagist | From 4.2.0 | 4.2.1 |
| `typo3/cms-core` | Packagist | From 4.2.0 | 4.2.1 |

Products: Apache Apache Webserver, Typo3 Typo3.

## How do I fix CVE-2008-2717?

Upgrade typo3/cms-core to a fixed version for your release line: 4.0.9, 4.1.7 or 4.2.1.

## Is CVE-2008-2717 being exploited?

There is no known exploitation of CVE-2008-2717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-2717 and fix it if it is affected.

What it is: CVE-2008-2717 is a medium-severity vulnerability in Typo3 Typo3, published on 16 Jun 2008. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-2717 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 4.0.0; fixed in 4.0.9
- typo3/cms-core (Packagist): affected from 4.0.0; fixed in 4.0.9
- typo3/cms-core (Packagist): affected from 4.1.0; fixed in 4.1.7
- typo3/cms-core (Packagist): affected from 4.1.0; fixed in 4.1.7
- typo3/cms-core (Packagist): affected from 4.2.0; fixed in 4.2.1
- typo3/cms-core (Packagist): affected from 4.2.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-2717/ (Markdown: https://insights.sbomify.com/CVE-2008-2717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-2717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-2717
- OSV: https://osv.dev/vulnerability/CVE-2008-2717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-2717/
Summaries are generated and may contain mistakes; the official description above is the record.
