# CVE-2008-2938: Apache Tomcat Directory Traversal vulnerability

> Remote attackers can read arbitrary files via encoded directory traversal sequences in the URI when specific configurations are enabled.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-m7xj-ccqc-p4g2

## What is CVE-2008-2938?

CVE-2008-2938 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 13 Aug 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370.  NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2008-2938?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.39 |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.39 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.27 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.27 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.18 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.18 |

Products: Apache Tomcat.

## How do I fix CVE-2008-2938?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.39, 5.5.27 or 6.0.18.

## Is CVE-2008-2938 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-2938 exists.

Public exploit code:

- Reproducible exploits for: CVE-2016-1240 CVE-2008-2938 CVE-2014-2064 CVE-2014-1904 (github_poc): https://github.com/Naramsim/Offensive
- Apache Tomcat < 6.0.18 - 'utf8' Directory Traversal (PoC) (exploitdb)
- Tomcat UTF-8 Directory Traversal Vulnerability (metasploit)
- TrendMicro Data Loss Prevention 5.5 Directory Traversal (metasploit)
- Apache Tomcat < 6.0.18 - 'utf8' Directory Traversal (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-2938 and fix it if it is affected.

What it is: CVE-2008-2938 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 13 Aug 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-2938 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.39
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.39
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.27
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.27
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.18
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-2938/ (Markdown: https://insights.sbomify.com/CVE-2008-2938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-2938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-2938
- OSV: https://osv.dev/vulnerability/CVE-2008-2938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-2938/
Summaries are generated and may contain mistakes; the official description above is the record.
