{"answers":{"affected":"3 open source packages ship an affected version, including mercurial. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-2942 in the wild and no public exploit code.","fix":"Upgrade mercurial to 1.0.2 or later.","what":"CVE-2008-2942 is a medium-severity path traversal vulnerability in n/a, published on 30 Jun 2008."},"fix_prompt":"Check this codebase for CVE-2008-2942 and fix it if it is affected.\n\nWhat it is: CVE-2008-2942 is a medium-severity path traversal vulnerability in n/a, published on 30 Jun 2008. \nExploitation: There is no known exploitation of CVE-2008-2942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mercurial (PyPI): affected all versions; fixed in 1.0.2\n- mercurial (PyPI): affected all versions; fixed in 1.0.2\n- mercurial (PyPI): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-2942/ (Markdown: https://insights.sbomify.com/CVE-2008-2942/index.md)","id":"CVE-2008-2942","markdown":"https://insights.sbomify.com/CVE-2008-2942/index.md","name":"CVE-2008-2942","record":{"aliases":["DEBIAN-CVE-2008-2942","GHSA-v2gw-x5jf-pgwv","PYSEC-2026-666"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"unknown","non_default_config":false,"product_category":"Mercurial version control","requires_auth":"none","summary":"Attackers can modify arbitrary files via directory traversal in Mercurial patch files, requiring user assistance to apply the malicious patch.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mercurial","vendor":"mercurial"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via \"..\" (dot dot) sequences in a patch file.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mercurial Directory traversal vulnerability","id":"CVE-2008-2942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2008"},"n_packages":3,"n_references":13,"next":{"headline":"Use after free in n/a","id":"CVE-2008-2943"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":null,"source":"GHSA-v2gw-x5jf-pgwv"},{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"GHSA-v2gw-x5jf-pgwv"},{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"PYSEC-2026-666"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2008-2941"},"products":["n/a"],"published":"2008-06-30","related":[{"cvss_score":9.8,"headline":"Mercurial mishandles integer addition and subtraction","id":"CVE-2018-13347","kev_date_added":null,"published":"2018-07-06"},{"cvss_score":9.1,"headline":"Mercurial Out-of-bounds Read vulnerability","id":"CVE-2018-17983","kev_date_added":null,"published":"2018-10-04"},{"cvss_score":7.5,"headline":"Mercurial Improper Input Validation vulnerability","id":"CVE-2018-13346","kev_date_added":null,"published":"2018-07-06"},{"cvss_score":7.5,"headline":"Mercurial Improper Input Validation vulnerability","id":"CVE-2018-13348","kev_date_added":null,"published":"2018-07-06"},{"cvss_score":7.5,"headline":"Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command","id":"CVE-2014-9462","kev_date_added":null,"published":"2015-03-31"},{"cvss_score":5.9,"headline":"Mercurial Improper Certificate Validation vulnerability","id":"CVE-2010-4237","kev_date_added":null,"published":"2019-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can modify arbitrary files via directory traversal in Mercurial patch files, requiring user assistance to apply the malicious patch.","url":"https://insights.sbomify.com/CVE-2008-2942/"}