# CVE-2008-2942: Mercurial Directory traversal vulnerability

> Attackers can modify arbitrary files via directory traversal in Mercurial patch files, requiring user assistance to apply the malicious patch.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2008
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-2942, GHSA-v2gw-x5jf-pgwv, PYSEC-2026-666

## What is CVE-2008-2942?

CVE-2008-2942 is a medium-severity path traversal vulnerability in n/a, published on 30 Jun 2008. 

### Official description

Directory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2008-2942?

3 open source packages ship an affected version, including mercurial. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 1.0.2 |
| `mercurial` | PyPI | All versions | 1.0.2 |
| `mercurial` | PyPI | All versions | 1.0.2 |

Products: Mercurial Mercurial.

## How do I fix CVE-2008-2942?

Upgrade mercurial to 1.0.2 or later.

## Is CVE-2008-2942 being exploited?

There is no known exploitation of CVE-2008-2942 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-13347](https://insights.sbomify.com/CVE-2018-13347/): Mercurial mishandles integer addition and subtraction (critical 9.8)
- [CVE-2018-17983](https://insights.sbomify.com/CVE-2018-17983/): Mercurial Out-of-bounds Read vulnerability (critical 9.1)
- [CVE-2018-13346](https://insights.sbomify.com/CVE-2018-13346/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2018-13348](https://insights.sbomify.com/CVE-2018-13348/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2014-9462](https://insights.sbomify.com/CVE-2014-9462/): Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-2942 and fix it if it is affected.

What it is: CVE-2008-2942 is a medium-severity path traversal vulnerability in n/a, published on 30 Jun 2008. 
Exploitation: There is no known exploitation of CVE-2008-2942 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 1.0.2
- mercurial (PyPI): affected all versions; fixed in 1.0.2
- mercurial (PyPI): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-2942/ (Markdown: https://insights.sbomify.com/CVE-2008-2942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-2942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-2942
- OSV: https://osv.dev/vulnerability/CVE-2008-2942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-2942/
Summaries are generated and may contain mistakes; the official description above is the record.
