{"answers":{"affected":"2 open source packages ship an affected version, including mehrwert/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-3032 in the wild and no public exploit code.","fix":"Upgrade mehrwert/phpmyadmin to 3.2.0 or later.","what":"CVE-2008-3032 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-3032 and fix it if it is affected.\n\nWhat it is: CVE-2008-3032 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-3032 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mehrwert/phpmyadmin (Packagist): affected all versions; fixed in 3.2.0\n- mehrwert/phpmyadmin (Packagist): affected all versions; fixed in 3.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-3032/ (Markdown: https://insights.sbomify.com/CVE-2008-3032/index.md)","id":"CVE-2008-3032","markdown":"https://insights.sbomify.com/CVE-2008-3032/index.md","name":"CVE-2008-3032","record":{"aliases":["GHSA-pm5m-9h5r-xcrg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 phpMyAdmin extension","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML into the phpMyAdmin extension for TYPO3, potentially stealing user data or hijacking sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"typo3"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the phpMyAdmin (phpmyadmin) extension 3.0.1 and earlier for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin extension for TYPO3 has Cross-site Scripting vulnerability","id":"CVE-2008-3032","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2008"},"n_packages":2,"n_references":4,"next":{"headline":"Missing authorization in n/a","id":"CVE-2008-3033"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"mehrwert/phpmyadmin","purl":null,"source":"GHSA-pm5m-9h5r-xcrg"},{"ecosystem":"Packagist","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"mehrwert/phpmyadmin","purl":"pkg:composer/mehrwert/phpmyadmin","source":"GHSA-pm5m-9h5r-xcrg"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2008-3031"},"products":["n/a"],"published":"2008-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into the phpMyAdmin extension for TYPO3, potentially stealing user data or hijacking sessions.","url":"https://insights.sbomify.com/CVE-2008-3032/"}