# CVE-2008-3032: phpMyAdmin extension for TYPO3 has Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML into the phpMyAdmin extension for TYPO3, potentially stealing user data or hijacking sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-pm5m-9h5r-xcrg

## What is CVE-2008-3032?

CVE-2008-3032 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the phpMyAdmin (phpmyadmin) extension 3.0.1 and earlier for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-3032?

2 open source packages ship an affected version, including mehrwert/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mehrwert/phpmyadmin` | Packagist | All versions | 3.2.0 |
| `mehrwert/phpmyadmin` | Packagist | All versions | 3.2.0 |

Products: Typo3 Phpmyadmin.

## How do I fix CVE-2008-3032?

Upgrade mehrwert/phpmyadmin to 3.2.0 or later.

## Is CVE-2008-3032 being exploited?

There is no known exploitation of CVE-2008-3032 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-3032 and fix it if it is affected.

What it is: CVE-2008-3032 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-3032 in the wild and no public exploit code.

Affected packages and fixed versions:
- mehrwert/phpmyadmin (Packagist): affected all versions; fixed in 3.2.0
- mehrwert/phpmyadmin (Packagist): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-3032/ (Markdown: https://insights.sbomify.com/CVE-2008-3032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-3032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-3032
- OSV: https://osv.dev/vulnerability/CVE-2008-3032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-3032/
Summaries are generated and may contain mistakes; the official description above is the record.
