# CVE-2008-3218: Drupal vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via taxonomy terms or OpenID values, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jul 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-6cj8-c359-p7q9

## What is CVE-2008-3218?

CVE-2008-3218 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 18 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.3 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) free tagging taxonomy terms, which are not properly handled on node preview pages, and (2) unspecified OpenID values.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-3218?

2 open source packages ship an affected version, including drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/drupal` | Packagist | From 6.0 | 6.3 |
| `drupal/drupal` | Packagist | From 6.0 | 6.3 |

Products: Drupal Drupal, Fedoraproject Fedora.

## How do I fix CVE-2008-3218?

Upgrade drupal/drupal to 6.3 or later.

## Is CVE-2008-3218 being exploited?

There is no known exploitation of CVE-2008-3218 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-3218 and fix it if it is affected.

What it is: CVE-2008-3218 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 18 Jul 2008. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-3218 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.3
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-3218/ (Markdown: https://insights.sbomify.com/CVE-2008-3218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-3218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-3218
- OSV: https://osv.dev/vulnerability/CVE-2008-3218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-3218/
Summaries are generated and may contain mistakes; the official description above is the record.
