# CVE-2008-3228: Joomla! doesn't configure .htaccess to apply certain security checks that "block common exploits" to SEF URLs

> Joomla fails to apply security checks to SEF URLs via .htaccess, potentially allowing attackers to bypass exploit blocking mechanisms.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-mxr8-pcpg-m23j

## What is CVE-2008-3228?

CVE-2008-3228 is a high-severity vulnerability in Joomla Joomla, published on 18 Jul 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Joomla! before 1.5.4 does not configure .htaccess to apply certain security checks that "block common exploits" to SEF URLs, which has unknown impact and remote attack vectors.

Weakness: CWE-16

## Which versions are affected by CVE-2008-3228?

2 open source packages ship an affected version, including joomla/joomla-platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/joomla-platform` | Packagist | All versions | 1.5.4 |
| `joomla/joomla-platform` | Packagist | All versions | 1.5.4 |

Products: Joomla Joomla.

## How do I fix CVE-2008-3228?

Upgrade joomla/joomla-platform to 1.5.4 or later.

## Is CVE-2008-3228 being exploited?

There is no known exploitation of CVE-2008-3228 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla

- [CVE-2008-3225](https://insights.sbomify.com/CVE-2008-3225/): Auth bypass in n/a (critical 10.0)
- [CVE-2006-1047](https://insights.sbomify.com/CVE-2006-1047/): Other in n/a (critical 10.0)
- [CVE-2006-0303](https://insights.sbomify.com/CVE-2006-0303/): Other in n/a (critical 10.0)
- [CVE-2005-3773](https://insights.sbomify.com/CVE-2005-3773/): Unspecified vulnerability in Joomla! (critical 10.0)
- [CVE-2006-1028](https://insights.sbomify.com/CVE-2006-1028/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-3228 and fix it if it is affected.

What it is: CVE-2008-3228 is a high-severity vulnerability in Joomla Joomla, published on 18 Jul 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-3228 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/joomla-platform (Packagist): affected all versions; fixed in 1.5.4
- joomla/joomla-platform (Packagist): affected all versions; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-3228/ (Markdown: https://insights.sbomify.com/CVE-2008-3228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-3228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-3228
- OSV: https://osv.dev/vulnerability/CVE-2008-3228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-3228/
Summaries are generated and may contain mistakes; the official description above is the record.
