{"answers":{"affected":"2 open source packages ship an affected version, including activerecord. It affects 2 products.","exploited":"There is no known exploitation of CVE-2008-4094 in the wild and no public exploit code.","fix":"Upgrade activerecord to 2.1.1 or later.","what":"CVE-2008-4094 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 30 Sep 2008. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2008-4094 and fix it if it is affected.\n\nWhat it is: CVE-2008-4094 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 30 Sep 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2008-4094 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord (RubyGems): affected all versions; fixed in 2.1.1\n- activerecord (RubyGems): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-4094/ (Markdown: https://insights.sbomify.com/CVE-2008-4094/index.md)","id":"CVE-2008-4094","markdown":"https://insights.sbomify.com/CVE-2008-4094/index.md","name":"CVE-2008-4094","record":{"aliases":["DEBIAN-CVE-2008-4094","GHSA-xf96-32q2-9rw2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands via limit and offset parameters in Ruby on Rails, potentially accessing or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rails ActiveRecord gem vulnerable to SQL injection","id":"CVE-2008-4094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"sql_injection","year":"2008"},"n_packages":2,"n_references":15,"next":{"headline":"Multiple unspecified vulnerabilities in the Importer in Flip4Mac WMV before 2.2.1 have unknown impact and attack vectors, different vulnerab","id":"CVE-2008-4095"},"packages":[{"ecosystem":"RubyGems","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-xf96-32q2-9rw2"},{"ecosystem":"RubyGems","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-xf96-32q2-9rw2"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2008-4093"},"products":["n/a"],"published":"2008-09-30","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via limit and offset parameters in Ruby on Rails, potentially accessing or modifying database contents.","url":"https://insights.sbomify.com/CVE-2008-4094/"}