CVE-2008-4308 Apache Tomcat information disclosure vulnerability
An attacker can read POST content from other requests due to improper error handling in Apache Tomcat's doRead method.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2008-4308?
CVE-2008-4308 is a low-severity vulnerability in Apache Tomcat, published on 26 Feb 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The doRead method in Apache Tomcat 4.1.32 through 4.1.34 and 5.5.10 through 5.5.20 does not return a -1 to indicate when a certain error condition has occurred, which can cause Tomcat to send POST content from one request to a different request.
Weakness: CWE-200
Which versions are affected by CVE-2008-4308?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.1.32 | 4.1.35 |
org.apache.tomcat:tomcat Maven | From 4.1.32 | 4.1.35 |
org.apache.tomcat:tomcat Maven | From 5.5.10 | 5.5.21 |
org.apache.tomcat:tomcat Maven | From 5.5.10 | 5.5.21 |
Products include Apache Tomcat.
How do I fix CVE-2008-4308?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.35 or 5.5.21.
Is CVE-2008-4308 being exploited?
There is no known exploitation of CVE-2008-4308 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-7g59-hm8v-cwmc.