CVE-2008-4456 Cross-site scripting in n/a

Low 2.6 Published Updated

Attackers can inject arbitrary web script or HTML into database cells, which executes when viewed by users of the MySQL command-line client using the --html option.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2008-4456?

CVE-2008-4456 is a low-severity cross-site scripting vulnerability in Mysql Mysql, published on 6 Oct 2008. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.

Weakness: CWE-79

Which versions are affected by CVE-2008-4456?

It affects 2 products.

Products include Mysql Mysql, Oracle Mysql.

How do I fix CVE-2008-4456?

No fix published yet.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2008-4456 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-4456 exists.

Public exploit code: 1 Exploit-DB entry.

All Mysql Mysql vulnerabilities

Sources

Also known as GHSA-wwgr-xr73-wm3j.

Is CVE-2008-4456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free