# CVE-2008-4456: Cross-site scripting in n/a

> Attackers can inject arbitrary web script or HTML into database cells, which executes when viewed by users of the MySQL command-line client using the --html option.

- **Severity:** Low 2.6 (`AV:N/AC:H/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-wwgr-xr73-wm3j

## What is CVE-2008-4456?

CVE-2008-4456 is a low-severity cross-site scripting vulnerability in Mysql Mysql, published on 6 Oct 2008. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document.  NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-4456?

It affects 2 products.


Products: Mysql Mysql, Oracle Mysql.

## How do I fix CVE-2008-4456?

No fix published yet.

## Is CVE-2008-4456 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-4456 exists.

Public exploit code:

- MySQL 5 - Command Line Client HTML Special Characters HTML Injection (exploitdb)

## Other vulnerabilities in Mysql Mysql

- [CVE-2004-0627](https://insights.sbomify.com/CVE-2004-0627/): Auth bypass in n/a (critical 10.0)
- [CVE-2004-0628](https://insights.sbomify.com/CVE-2004-0628/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-2446](https://insights.sbomify.com/CVE-2009-2446/): Other in n/a (high 8.5)
- [CVE-2012-0553](https://insights.sbomify.com/CVE-2012-0553/): Memory corruption in n/a (high 7.5)
- [CVE-2013-1492](https://insights.sbomify.com/CVE-2013-1492/): Memory corruption in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-4456 and fix it if it is affected.

What it is: CVE-2008-4456 is a low-severity cross-site scripting vulnerability in Mysql Mysql, published on 6 Oct 2008. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-4456 exists.

Affected product: Mysql Mysql. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-4456/ (Markdown: https://insights.sbomify.com/CVE-2008-4456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-4456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-4456
- OSV: https://osv.dev/vulnerability/CVE-2008-4456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-4456/
Summaries are generated and may contain mistakes; the official description above is the record.
