{"answers":{"affected":"2 open source packages ship an affected version, including drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-4793 in the wild and no public exploit code.","fix":"Upgrade drupal/drupal to 5.11 or later.","what":"CVE-2008-4793 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 29 Oct 2008. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2008-4793 and fix it if it is affected.\n\nWhat it is: CVE-2008-4793 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 29 Oct 2008. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2008-4793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/drupal (Packagist): affected from 5.0; fixed in 5.11\n- drupal/drupal (Packagist): affected from 5.0; fixed in 5.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-4793/ (Markdown: https://insights.sbomify.com/CVE-2008-4793/index.md)","id":"CVE-2008-4793","markdown":"https://insights.sbomify.com/CVE-2008-4793/index.md","name":"CVE-2008-4793","record":{"aliases":["GHSA-ph2j-5hxq-gxrr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal CMS","requires_auth":"low_privilege","summary":"Remote attackers can bypass node validation in Drupal 5.x, potentially modifying data or bypassing security controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal Node Validation Bypass in the node module API","id":"CVE-2008-4793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"missing_authorization","year":"2008"},"n_packages":2,"n_references":4,"next":{"headline":"Command injection in n/a","id":"CVE-2008-4794"},"packages":[{"ecosystem":"Packagist","fixed":["5.11"],"introduced":["5.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-ph2j-5hxq-gxrr"},{"ecosystem":"Packagist","fixed":["5.11"],"introduced":["5.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-ph2j-5hxq-gxrr"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2008-4792"},"products":["n/a"],"published":"2008-10-29","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can bypass node validation in Drupal 5.x, potentially modifying data or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2008-4793/"}