# CVE-2008-4793: Drupal Node Validation Bypass in the node module API

> Remote attackers can bypass node validation in Drupal 5.x, potentially modifying data or bypassing security controls.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-ph2j-5hxq-gxrr

## What is CVE-2008-4793?

CVE-2008-4793 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 29 Oct 2008. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Weakness: CWE-264

## Which versions are affected by CVE-2008-4793?

2 open source packages ship an affected version, including drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/drupal` | Packagist | From 5.0 | 5.11 |
| `drupal/drupal` | Packagist | From 5.0 | 5.11 |

Products: Drupal Drupal.

## How do I fix CVE-2008-4793?

Upgrade drupal/drupal to 5.11 or later.

## Is CVE-2008-4793 being exploited?

There is no known exploitation of CVE-2008-4793 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-4793 and fix it if it is affected.

What it is: CVE-2008-4793 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 29 Oct 2008. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-4793 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/drupal (Packagist): affected from 5.0; fixed in 5.11
- drupal/drupal (Packagist): affected from 5.0; fixed in 5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-4793/ (Markdown: https://insights.sbomify.com/CVE-2008-4793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-4793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-4793
- OSV: https://osv.dev/vulnerability/CVE-2008-4793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-4793/
Summaries are generated and may contain mistakes; the official description above is the record.
