{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-4865 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2008-4865 is a high-severity path traversal vulnerability in n/a, published on 31 Oct 2008. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-4865 and fix it if it is affected.\n\nWhat it is: CVE-2008-4865 is a high-severity path traversal vulnerability in n/a, published on 31 Oct 2008. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-4865 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-4865/ (Markdown: https://insights.sbomify.com/CVE-2008-4865/index.md)","id":"CVE-2008-4865","markdown":"https://insights.sbomify.com/CVE-2008-4865/index.md","name":"CVE-2008-4865","record":{"aliases":["DEBIAN-CVE-2008-4865","GHSA-gjj4-r6j8-99mm","RHEA-2010:0272","openSUSE-SU-2024:11492-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Valgrind memory debugger","requires_auth":"none","summary":"Local attackers can execute arbitrary code by placing a malicious .valgrindrc file in the current working directory, affecting Valgrind users.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"valgrind","vendor":"valgrind"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"AV:L/AC:L/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[],"description":"Untrusted search path vulnerability in valgrind before 3.4.0 allows local users to execute arbitrary programs via a Trojan horse .valgrindrc file in the current working directory, as demonstrated using a malicious --db-command options.  NOTE: the severity of this issue has been disputed, but CVE is including this issue because execution of a program from an untrusted directory is a common scenario.","ecosystems":["Red Hat:enterprise_linux:5::client_workstation","Red Hat:enterprise_linux:5::server","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2008-4865","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2008"},"n_packages":5,"n_references":8,"next":{"headline":"Memory corruption in n/a","id":"CVE-2008-4866"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:5::client_workstation","fixed":["1:3.5.0-1.el5"],"introduced":["0"],"last_affected":[],"package":"valgrind","purl":"pkg:rpm/redhat/valgrind","source":"RHEA-2010:0272"},{"ecosystem":"Red Hat:enterprise_linux:5::client_workstation","fixed":["1:3.5.0-1.el5"],"introduced":["0"],"last_affected":[],"package":"valgrind-devel","purl":"pkg:rpm/redhat/valgrind-devel","source":"RHEA-2010:0272"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["1:3.5.0-1.el5"],"introduced":["0"],"last_affected":[],"package":"valgrind","purl":"pkg:rpm/redhat/valgrind","source":"RHEA-2010:0272"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["1:3.5.0-1.el5"],"introduced":["0"],"last_affected":[],"package":"valgrind-devel","purl":"pkg:rpm/redhat/valgrind-devel","source":"RHEA-2010:0272"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.17.0-2.3"],"introduced":["0"],"last_affected":[],"package":"valgrind","purl":"pkg:rpm/opensuse/valgrind\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11492-1"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2008-4864"},"products":["n/a"],"published":"2008-10-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHEA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Local attackers can execute arbitrary code by placing a malicious .valgrindrc file in the current working directory, affecting Valgrind users.","url":"https://insights.sbomify.com/CVE-2008-4865/"}