{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5499 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2008-5499 is a critical code injection vulnerability in n/a, published on 18 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-5499 and fix it if it is affected.\n\nWhat it is: CVE-2008-5499 is a critical code injection vulnerability in n/a, published on 18 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5499 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-5499/ (Markdown: https://insights.sbomify.com/CVE-2008-5499/index.md)","id":"CVE-2008-5499","markdown":"https://insights.sbomify.com/CVE-2008-5499/index.md","name":"CVE-2008-5499","record":{"aliases":["GHSA-jmfj-rgc6-43mh","RHSA-2008:1047"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on Linux systems by tricking users into opening a crafted SWF file in Adobe Flash Player.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"flash_player_for_linux","vendor":"adobe"}],"cvss":{"score":9.3,"severity":"critical","source":"nvd","vector":"AV:N/AC:M/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Unspecified vulnerability in Adobe Flash Player for Linux 10.0.12.36, and 9.0.151.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file.","ecosystems":["Red Hat:rhel_extras:3","Red Hat:rhel_extras:4","Red Hat:rhel_extras:5::client","Red Hat:rhel_extras:5::server"],"exploits":{"exploitdb":1,"first_seen":"2008-12-17","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2008-12-17","kind":"metasploit","ref":"exploit/linux/browser/adobe_flashplayer_aslaunch","stars":null,"title":"Adobe Flash Player ActionScript Launch Command Execution Vulnerability"},{"date":"2012-04-20","kind":"exploitdb","ref":"18761","stars":null,"title":"Adobe Flash Player - ActionScript Launch Command Execution (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Code injection in n/a","id":"CVE-2008-5499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2008"},"n_packages":4,"n_references":13,"next":{"headline":"Integer overflow in n/a","id":"CVE-2008-5500"},"packages":[{"ecosystem":"Red Hat:rhel_extras:3","fixed":["0:9.0.152.0-1.el3.with.oss"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2008:1047"},{"ecosystem":"Red Hat:rhel_extras:4","fixed":["0:9.0.152.0-1.el4"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2008:1047"},{"ecosystem":"Red Hat:rhel_extras:5::client","fixed":["0:10.0.15.3-2.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2008:1047"},{"ecosystem":"Red Hat:rhel_extras:5::server","fixed":["0:10.0.15.3-2.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2008:1047"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2008-5498"},"products":["n/a"],"published":"2008-12-18","related":[{"cvss_score":4.6,"headline":"Path traversal in n/a","id":"CVE-2009-0521","kev_date_added":null,"published":"2009-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code on Linux systems by tricking users into opening a crafted SWF file in Adobe Flash Player.","url":"https://insights.sbomify.com/CVE-2008-5499/"}