CVE-2008-5515 Directory Traversal in Apache Tomcat
Remote attackers can bypass access restrictions and perform directory traversal attacks to read sensitive files via crafted requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2008-5515?
CVE-2008-5515 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 16 Jun 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, 6.0.0 through 6.0.18, and possibly earlier versions normalizes the target pathname before filtering the query string when using the RequestDispatcher method, which allows remote attackers to bypass intended access restrictions and conduct directory traversal attacks via .. (dot dot) sequences and the WEB-INF directory in a Request.
Weakness: CWE-22
Which versions are affected by CVE-2008-5515?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.40 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.40 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.28 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.28 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.20 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.20 |
Products include Apache Tomcat.
How do I fix CVE-2008-5515?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.40, 5.5.28 or 6.0.20.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2008-5515 being exploited?
There is no known exploitation of CVE-2008-5515 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-9737-qmgc-hfr9.