# CVE-2008-5518: Apache Geronimo Application Server multiple directory traversal vulnerabilities

> Remote attackers with admin access can upload files to arbitrary directories via path traversal in the web console, potentially leading to code execution.

- **Severity:** Critical 9.4 (`AV:N/AC:L/Au:N/C:C/I:C/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-xm92-rf24-h74w

## What is CVE-2008-5518?

CVE-2008-5518 is a critical path traversal vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Multiple directory traversal vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 on Windows allow remote attackers to upload files to arbitrary directories via directory traversal sequences in the (1) group, (2) artifact, (3) version, or (4) fileType parameter to console/portal//Services/Repository (aka the Services/Repository portlet); the (5) createDB parameter to console/portal/Embedded DB/DB Manager (aka the Embedded DB/DB Manager portlet); or the (6) filename parameter to the createKeystore script in the Security/Keystores portlet.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2008-5518?

2 open source packages ship an affected version, including org.apache.geronimo.plugins:console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geronimo.plugins:console` | Maven | From 2.1.0 | 2.1.4 |
| `org.apache.geronimo.plugins:console` | Maven | From 2.1.0 | 2.1.4 |

Products: Apache Geronimo.

## How do I fix CVE-2008-5518?

Upgrade org.apache.geronimo.plugins:console to 2.1.4 or later.

## Is CVE-2008-5518 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5518 exists.

Public exploit code:

- Apache Geronimo 2.1.3 - Multiple Directory Traversal Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2013-1777](https://insights.sbomify.com/CVE-2013-1777/): Apache Geronimo JMX Remoting functionality allows remote code execution in 3.x before v3.0.1 (critical 10.0)
- [CVE-2007-4548](https://insights.sbomify.com/CVE-2007-4548/): Auth bypass in n/a (critical 10.0)
- [CVE-2011-5034](https://insights.sbomify.com/CVE-2011-5034/): Apache Geronimo Hash Collisions Cause DoS (high 7.8)
- [CVE-2007-5797](https://insights.sbomify.com/CVE-2007-5797/): Auth bypass in n/a (high 7.5)
- [CVE-2009-0039](https://insights.sbomify.com/CVE-2009-0039/): Apache Geronimo Application Server CSRF vulnerabilities (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-5518 and fix it if it is affected.

What it is: CVE-2008-5518 is a critical path traversal vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5518 exists.

Affected packages and fixed versions:
- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4
- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-5518/ (Markdown: https://insights.sbomify.com/CVE-2008-5518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-5518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-5518
- OSV: https://osv.dev/vulnerability/CVE-2008-5518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-5518/
Summaries are generated and may contain mistakes; the official description above is the record.
