# CVE-2008-5619: PHPMailer susceptible to arbitrary code execution

> Remote attackers can execute arbitrary code via crafted input processed by the preg_replace function with the eval switch in the html2text.php library.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2008
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-5619, GHSA-v5c9-mmw9-829q

## What is CVE-2008-5619?

CVE-2008-5619 is a critical code injection vulnerability in Roundcube Webmail, published on 17 Dec 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

html2text.php in Chuggnutt HTML to Text Converter, as used in PHPMailer before 5.2.10, RoundCube Webmail (roundcubemail) 0.2-1.alpha and 0.2-3.beta, Mahara, and AtMail Open 1.03, allows remote attackers to execute arbitrary code via crafted input that is processed by the preg_replace function with the eval switch.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2008-5619?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 5.2.10 |
| `phpmailer/phpmailer` | Packagist | All versions | 5.2.10 |

Products: Roundcube Webmail.

## How do I fix CVE-2008-5619?

Upgrade phpmailer/phpmailer to 5.2.10 or later.

## Is CVE-2008-5619 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5619 exists.

Public exploit code:

- Roundcube Webmail 0.2-3 Beta - Code Execution (exploitdb)
- Roundcube Webmail 0.2b - Remote Code Execution (exploitdb)

## Other vulnerabilities in Roundcube Webmail

- [CVE-2024-42009](https://insights.sbomify.com/CVE-2024-42009/): RoundCube Webmail Cross-Site Scripting (critical 9.3, exploited in the wild)
- [CVE-2025-68461](https://insights.sbomify.com/CVE-2025-68461/): RoundCube Webmail Cross-site Scripting (high 7.2, exploited in the wild)
- [CVE-2024-37385](https://insights.sbomify.com/CVE-2024-37385/): Command injection in n/a (critical 9.8)
- [CVE-2024-42008](https://insights.sbomify.com/CVE-2024-42008/): Cross-site scripting in n/a (critical 9.3)
- [CVE-2026-74997](https://insights.sbomify.com/CVE-2026-74997/): Command injection in Webmail (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-5619 and fix it if it is affected.

What it is: CVE-2008-5619 is a critical code injection vulnerability in Roundcube Webmail, published on 17 Dec 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-5619 exists.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.10
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-5619/ (Markdown: https://insights.sbomify.com/CVE-2008-5619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-5619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-5619
- OSV: https://osv.dev/vulnerability/CVE-2008-5619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-5619/
Summaries are generated and may contain mistakes; the official description above is the record.
