{"answers":{"affected":"3 open source packages ship an affected version, including trac and Trac. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-5646 in the wild and no public exploit code.","fix":"Upgrade trac to 0.11.2 or later.","what":"CVE-2008-5646 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2008. It can be exploited over the network."},"fix_prompt":"Check this codebase for CVE-2008-5646 and fix it if it is affected.\n\nWhat it is: CVE-2008-5646 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2008. It can be exploited over the network.\nExploitation: There is no known exploitation of CVE-2008-5646 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trac (PyPI): affected all versions; fixed in 0.11.2\n- trac (PyPI): affected all versions; fixed in 0.11.2\n- Trac (PyPI): affected all versions; fixed in 0.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-5646/ (Markdown: https://insights.sbomify.com/CVE-2008-5646/index.md)","id":"CVE-2008-5646","markdown":"https://insights.sbomify.com/CVE-2008-5646/index.md","name":"CVE-2008-5646","record":{"aliases":["DEBIAN-CVE-2008-5646","GHSA-437p-qw95-wqqr","PYSEC-2008-6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Trac wiki system","requires_auth":"unknown","summary":"Attackers can cause a denial of service in Trac via specific wiki markup, affecting web application availability.","user_interaction":"unknown","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"trac","vendor":"trac"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Unspecified vulnerability in Trac before 0.11.2 allows attackers to cause a denial of service via unknown attack vectors related to \"certain wiki markup.\"","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trac vulnerable to denial of service","id":"CVE-2008-5646","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2008"},"n_packages":3,"n_references":5,"next":{"headline":"Trac has vulnerability in HTML sanitizer filter","id":"CVE-2008-5647"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"Trac","purl":null,"source":"GHSA-437p-qw95-wqqr"},{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"trac","purl":"pkg:pypi/trac","source":"GHSA-437p-qw95-wqqr"},{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"trac","purl":"pkg:pypi/trac","source":"PYSEC-2008-6"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2008-5645"},"products":["n/a"],"published":"2008-12-17","related":[{"cvss_score":5,"headline":"Trac has vulnerability in HTML sanitizer filter","id":"CVE-2008-5647","kev_date_added":null,"published":"2008-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in Trac via specific wiki markup, affecting web application availability.","url":"https://insights.sbomify.com/CVE-2008-5646/"}