# CVE-2008-5646: Trac vulnerable to denial of service

> Attackers can cause a denial of service in Trac via specific wiki markup, affecting web application availability.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 17 Dec 2008
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-5646, GHSA-437p-qw95-wqqr, PYSEC-2008-6

## What is CVE-2008-5646?

CVE-2008-5646 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2008. It can be exploited over the network.

### Official description

Unspecified vulnerability in Trac before 0.11.2 allows attackers to cause a denial of service via unknown attack vectors related to "certain wiki markup."

## Which versions are affected by CVE-2008-5646?

3 open source packages ship an affected version, including trac and Trac. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trac` | PyPI | All versions | 0.11.2 |
| `trac` | PyPI | All versions | 0.11.2 |
| `Trac` | PyPI | All versions | 0.11.2 |

Products: Trac Trac.

## How do I fix CVE-2008-5646?

Upgrade trac to 0.11.2 or later.

## Is CVE-2008-5646 being exploited?

There is no known exploitation of CVE-2008-5646 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-5647](https://insights.sbomify.com/CVE-2008-5647/): Trac has vulnerability in HTML sanitizer filter (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-5646 and fix it if it is affected.

What it is: CVE-2008-5646 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2008. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2008-5646 in the wild and no public exploit code.

Affected packages and fixed versions:
- trac (PyPI): affected all versions; fixed in 0.11.2
- trac (PyPI): affected all versions; fixed in 0.11.2
- Trac (PyPI): affected all versions; fixed in 0.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-5646/ (Markdown: https://insights.sbomify.com/CVE-2008-5646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-5646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-5646
- OSV: https://osv.dev/vulnerability/CVE-2008-5646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-5646/
Summaries are generated and may contain mistakes; the official description above is the record.
