{"answers":{"affected":"3 open source packages ship an affected version, including trac and Trac. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-5647 in the wild and no public exploit code.","fix":"Upgrade trac to 0.11.2 or later.","what":"CVE-2008-5647 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-5647 and fix it if it is affected.\n\nWhat it is: CVE-2008-5647 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-5647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trac (PyPI): affected all versions; fixed in 0.11.2\n- trac (PyPI): affected all versions; fixed in 0.11.2\n- Trac (PyPI): affected all versions; fixed in 0.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-5647/ (Markdown: https://insights.sbomify.com/CVE-2008-5647/index.md)","id":"CVE-2008-5647","markdown":"https://insights.sbomify.com/CVE-2008-5647/index.md","name":"CVE-2008-5647","record":{"aliases":["DEBIAN-CVE-2008-5647","GHSA-ww53-wxxr-8f9w","PYSEC-2008-7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Trac web application","requires_auth":"none","summary":"Attackers can bypass the HTML sanitizer to conduct phishing attacks, requiring user interaction to exploit.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"trac","vendor":"trac"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Unspecified vulnerability in the HTML sanitizer filter in Trac before 0.11.2 allows attackers to conduct phishing attacks via unknown attack vectors.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trac has vulnerability in HTML sanitizer filter","id":"CVE-2008-5647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2008"},"n_packages":3,"n_references":5,"next":{"headline":"SQL injection in n/a","id":"CVE-2008-5648"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"Trac","purl":null,"source":"GHSA-ww53-wxxr-8f9w"},{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"trac","purl":"pkg:pypi/trac","source":"GHSA-ww53-wxxr-8f9w"},{"ecosystem":"PyPI","fixed":["0.11.2"],"introduced":["0"],"last_affected":[],"package":"trac","purl":"pkg:pypi/trac","source":"PYSEC-2008-7"}],"prev":{"headline":"Trac vulnerable to denial of service","id":"CVE-2008-5646"},"products":["n/a"],"published":"2008-12-17","related":[{"cvss_score":7.5,"headline":"Trac vulnerable to denial of service","id":"CVE-2008-5646","kev_date_added":null,"published":"2008-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can bypass the HTML sanitizer to conduct phishing attacks, requiring user interaction to exploit.","url":"https://insights.sbomify.com/CVE-2008-5647/"}