{"answers":{"affected":"2 open source packages ship an affected version, including com.github.seasarorg.mayaa:mayaa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-5720 in the wild and no public exploit code.","fix":"Upgrade com.github.seasarorg.mayaa:mayaa to 1.1.23 or later.","what":"CVE-2008-5720 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-5720 and fix it if it is affected.\n\nWhat it is: CVE-2008-5720 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Dec 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-5720 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.github.seasarorg.mayaa:mayaa (Maven): affected all versions; fixed in 1.1.23\n- com.github.seasarorg.mayaa:mayaa (Maven): affected all versions; fixed in 1.1.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-5720/ (Markdown: https://insights.sbomify.com/CVE-2008-5720/index.md)","id":"CVE-2008-5720","markdown":"https://insights.sbomify.com/CVE-2008-5720/index.md","name":"CVE-2008-5720","record":{"aliases":["GHSA-m3p9-c7p3-xxmp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mayaa web framework","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the default error page, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mayaa","vendor":"seasar"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Mayaa before 1.1.23 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the default error page for the org.seasar.mayaa.impl.engine.PageNotFoundException exception and possibly other exceptions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mayaa Cross-site Scripting vulnerability","id":"CVE-2008-5720","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2008"},"n_packages":2,"n_references":7,"next":{"headline":"Auth bypass in n/a","id":"CVE-2008-5721"},"packages":[{"ecosystem":"Maven","fixed":["1.1.23"],"introduced":["0"],"last_affected":[],"package":"com.github.seasarorg.mayaa:mayaa","purl":null,"source":"GHSA-m3p9-c7p3-xxmp"},{"ecosystem":"Maven","fixed":["1.1.23"],"introduced":["0"],"last_affected":[],"package":"com.github.seasarorg.mayaa:mayaa","purl":"pkg:maven/com.github.seasarorg.mayaa/mayaa","source":"GHSA-m3p9-c7p3-xxmp"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2008-5719"},"products":["n/a"],"published":"2008-12-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the default error page, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2008-5720/"}