CVE-2008-6504 Improper Input Validation in OpenSymphony XWork
Remote attackers can execute arbitrary OGNL statements and modify server-side context objects in XWork/Struts applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2008-6504?
CVE-2008-6504 is a medium-severity code injection vulnerability in Apache Struts, published on 23 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ParametersInterceptor in OpenSymphony XWork 2.0.x before 2.0.6 and 2.1.x before 2.1.2, as used in Apache Struts and other products, does not properly restrict # (pound sign) references to context objects, which allows remote attackers to execute Object-Graph Navigation Language (OGNL) statements and modify server-side context objects, as demonstrated by use of a \u0023 representation for the # character.
Weakness: CWE-20
Which versions are affected by CVE-2008-6504?
4 open source packages ship an affected version, including com.opensymphony:xwork. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.opensymphony:xwork Maven | All versions | 2.0.6 |
com.opensymphony:xwork Maven | All versions | 2.0.6 |
com.opensymphony:xwork Maven | From 2.1.0 | 2.1.2 |
com.opensymphony:xwork Maven | From 2.1.0 | 2.1.2 |
Products include Apache Struts, Opensymphony Xwork.
How do I fix CVE-2008-6504?
Upgrade com.opensymphony:xwork to a fixed version for your release line: 2.0.6 or 2.1.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2008-6504 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-6504 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-wxw2-2mx5-c5qf.