# CVE-2008-6504: Improper Input Validation in OpenSymphony XWork

> Remote attackers can execute arbitrary OGNL statements and modify server-side context objects in XWork/Struts applications.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-wxw2-2mx5-c5qf

## What is CVE-2008-6504?

CVE-2008-6504 is a medium-severity code injection vulnerability in Apache Struts, published on 23 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ParametersInterceptor in OpenSymphony XWork 2.0.x before 2.0.6 and 2.1.x before 2.1.2, as used in Apache Struts and other products, does not properly restrict # (pound sign) references to context objects, which allows remote attackers to execute Object-Graph Navigation Language (OGNL) statements and modify server-side context objects, as demonstrated by use of a \u0023 representation for the # character.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2008-6504?

4 open source packages ship an affected version, including com.opensymphony:xwork. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.opensymphony:xwork` | Maven | All versions | 2.0.6 |
| `com.opensymphony:xwork` | Maven | All versions | 2.0.6 |
| `com.opensymphony:xwork` | Maven | From 2.1.0 | 2.1.2 |
| `com.opensymphony:xwork` | Maven | From 2.1.0 | 2.1.2 |

Products: Apache Struts, Opensymphony Xwork.

## How do I fix CVE-2008-6504?

Upgrade com.opensymphony:xwork to a fixed version for your release line: 2.0.6 or 2.1.2.

## Is CVE-2008-6504 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-6504 exists.

Public exploit code:

- XWork < 2.0.11.2 - 'ParameterInterceptor' Class OGNL Security Bypass (exploitdb)

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-6504 and fix it if it is affected.

What it is: CVE-2008-6504 is a medium-severity code injection vulnerability in Apache Struts, published on 23 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-6504 exists.

Affected packages and fixed versions:
- com.opensymphony:xwork (Maven): affected all versions; fixed in 2.0.6
- com.opensymphony:xwork (Maven): affected all versions; fixed in 2.0.6
- com.opensymphony:xwork (Maven): affected from 2.1.0; fixed in 2.1.2
- com.opensymphony:xwork (Maven): affected from 2.1.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-6504/ (Markdown: https://insights.sbomify.com/CVE-2008-6504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-6504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-6504
- OSV: https://osv.dev/vulnerability/CVE-2008-6504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-6504/
Summaries are generated and may contain mistakes; the official description above is the record.
