CVE-2008-6505 Apache Struts directory traversal vulnerability
Remote attackers can read arbitrary files via directory traversal in Apache Struts, exposing sensitive data to unauthorized users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2008-6505?
CVE-2008-6505 is a medium-severity path traversal vulnerability in Apache Struts, published on 23 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Multiple directory traversal vulnerabilities in Apache Struts 2.0.x before 2.0.12 and 2.1.x before 2.1.3 allow remote attackers to read arbitrary files via a ..%252f (encoded dot dot slash) in a URI with a /struts/ path, related to (1) FilterDispatcher in 2.0.x and (2) DefaultStaticContentLoader in 2.1.x.
Weakness: CWE-22
Which versions are affected by CVE-2008-6505?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.0.12 |
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.0.12 |
org.apache.struts:struts2-core Maven | From 2.1.0 | 2.1.3 |
org.apache.struts:struts2-core Maven | From 2.1.0 | 2.1.3 |
Products include Apache Struts.
How do I fix CVE-2008-6505?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.0.12 or 2.1.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2008-6505 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-6505 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-wv7g-xhvw-8hcp.