# CVE-2008-6507: phpBB vulnerable to sensitive information disclosure

> Attackers can view sensitive content from password-protected forums by quoting posts in private messages without authentication.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2009
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jw8f-q84g-r3vm

## What is CVE-2008-6507?

CVE-2008-6507 is a medium-severity vulnerability in n/a, published on 23 Mar 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Unspecified vulnerability in phpBB before 3.0.4 allows attackers to obtain sensitive information via unknown vectors related to the lack of password prompts for a private message that quotes a post in a password-protected forum.

## Which versions are affected by CVE-2008-6507?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.0.4 |
| `phpbb/phpbb` | Packagist | All versions | 3.0.4 |

Products: Phpbb Phpbb.

## How do I fix CVE-2008-6507?

Upgrade phpbb/phpbb to 3.0.4 or later.

## Is CVE-2008-6507 being exploited?

There is no known exploitation of CVE-2008-6507 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-6507 and fix it if it is affected.

What it is: CVE-2008-6507 is a medium-severity vulnerability in n/a, published on 23 Mar 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-6507 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.4
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-6507/ (Markdown: https://insights.sbomify.com/CVE-2008-6507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-6507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-6507
- OSV: https://osv.dev/vulnerability/CVE-2008-6507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-6507/
Summaries are generated and may contain mistakes; the official description above is the record.
