{"answers":{"affected":"3 open source packages ship an affected version, including formencode and FormEncode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-6547 in the wild and no public exploit code.","fix":"Upgrade formencode to 1.0.1 or later.","what":"CVE-2008-6547 is a high-severity vulnerability in n/a, published on 30 Mar 2009. It can be exploited over the network."},"fix_prompt":"Check this codebase for CVE-2008-6547 and fix it if it is affected.\n\nWhat it is: CVE-2008-6547 is a high-severity vulnerability in n/a, published on 30 Mar 2009. It can be exploited over the network.\nExploitation: There is no known exploitation of CVE-2008-6547 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- formencode (PyPI): affected all versions; fixed in 1.0.1\n- formencode (PyPI): affected from 1.0; fixed in 1.0.1\n- FormEncode (PyPI): affected from 1.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-6547/ (Markdown: https://insights.sbomify.com/CVE-2008-6547/index.md)","id":"CVE-2008-6547","markdown":"https://insights.sbomify.com/CVE-2008-6547/index.md","name":"CVE-2008-6547","record":{"aliases":["DEBIAN-CVE-2008-6547","GHSA-9jp4-68vc-r8wq","PYSEC-2009-5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Python validation library","requires_auth":"unknown","summary":"Attackers can bypass intended access restrictions in FormEncode by exploiting a failure to apply chained validators, requiring the feature to be enabled.","user_interaction":"unknown","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"formencode","vendor":"formencode"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"schema.py in FormEncode for Python (python-formencode) 1.0 does not apply the chained_validators feature, which allows attackers to bypass intended access restrictions via unknown vectors.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FormEncode Access Restrictions Bypass","id":"CVE-2008-6547","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2008"},"n_packages":3,"n_references":8,"next":{"headline":"MoinMoin improper access control on the included page for the rst parser","id":"CVE-2008-6548"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["1.0"],"last_affected":[],"package":"FormEncode","purl":null,"source":"GHSA-9jp4-68vc-r8wq"},{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"formencode","purl":"pkg:pypi/formencode","source":"PYSEC-2009-5"},{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["1.0"],"last_affected":[],"package":"formencode","purl":"pkg:pypi/formencode","source":"GHSA-9jp4-68vc-r8wq"}],"prev":{"headline":"Other in n/a","id":"CVE-2008-6546"},"products":["n/a"],"published":"2009-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can bypass intended access restrictions in FormEncode by exploiting a failure to apply chained validators, requiring the feature to be enabled.","url":"https://insights.sbomify.com/CVE-2008-6547/"}