# CVE-2008-6547: FormEncode Access Restrictions Bypass

> Attackers can bypass intended access restrictions in FormEncode by exploiting a failure to apply chained validators, requiring the feature to be enabled.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 30 Mar 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-6547, GHSA-9jp4-68vc-r8wq, PYSEC-2009-5

## What is CVE-2008-6547?

CVE-2008-6547 is a high-severity vulnerability in n/a, published on 30 Mar 2009. It can be exploited over the network.

### Official description

schema.py in FormEncode for Python (python-formencode) 1.0 does not apply the chained_validators feature, which allows attackers to bypass intended access restrictions via unknown vectors.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2008-6547?

3 open source packages ship an affected version, including formencode and FormEncode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `formencode` | PyPI | All versions | 1.0.1 |
| `formencode` | PyPI | From 1.0 | 1.0.1 |
| `FormEncode` | PyPI | From 1.0 | 1.0.1 |

Products: Formencode Formencode.

## How do I fix CVE-2008-6547?

Upgrade formencode to 1.0.1 or later.

## Is CVE-2008-6547 being exploited?

There is no known exploitation of CVE-2008-6547 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-6547 and fix it if it is affected.

What it is: CVE-2008-6547 is a high-severity vulnerability in n/a, published on 30 Mar 2009. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2008-6547 in the wild and no public exploit code.

Affected packages and fixed versions:
- formencode (PyPI): affected all versions; fixed in 1.0.1
- formencode (PyPI): affected from 1.0; fixed in 1.0.1
- FormEncode (PyPI): affected from 1.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-6547/ (Markdown: https://insights.sbomify.com/CVE-2008-6547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-6547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-6547
- OSV: https://osv.dev/vulnerability/CVE-2008-6547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-6547/
Summaries are generated and may contain mistakes; the official description above is the record.
