{"answers":{"affected":"3 open source packages ship an affected version, including moin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-6549 in the wild and no public exploit code.","fix":"Upgrade moin to 1.6.1 or later.","what":"CVE-2008-6549 is a medium-severity denial of service vulnerability in n/a, published on 30 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2008-6549 and fix it if it is affected.\n\nWhat it is: CVE-2008-6549 is a medium-severity denial of service vulnerability in n/a, published on 30 Mar 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2008-6549 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected all versions; fixed in 1.6.1\n- moin (PyPI): affected all versions; fixed in 1.6.1\n- moin (PyPI): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-6549/ (Markdown: https://insights.sbomify.com/CVE-2008-6549/index.md)","id":"CVE-2008-6549","markdown":"https://insights.sbomify.com/CVE-2008-6549/index.md","name":"CVE-2008-6549","record":{"aliases":["GHSA-wjjc-m3fc-fcm8","PYSEC-2009-12"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MoinMoin Wiki","requires_auth":"none","summary":"Remote attackers can cause a denial of service via segmentation fault in MoinMoin due to thread-unsafe password checking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moinmoin","vendor":"moinmo"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"The password_checker function in config/multiconfig.py in MoinMoin 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MoinMoin Denial of Service vulnerability via password_checker function","id":"CVE-2008-6549","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2008"},"n_packages":3,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2008-6550"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"moin","purl":null,"source":"GHSA-wjjc-m3fc-fcm8"},{"ecosystem":"PyPI","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-wjjc-m3fc-fcm8"},{"ecosystem":"PyPI","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2009-12"}],"prev":{"headline":"MoinMoin improper access control on the included page for the rst parser","id":"CVE-2008-6548"},"products":["n/a"],"published":"2009-03-30","related":[{"cvss_score":8.7,"headline":"malicious SVG attachment causing stored XSS vulnerability in MoinMoin","id":"CVE-2020-15275","kev_date_added":null,"published":"2020-11-11"},{"cvss_score":7.5,"headline":"MoinMoin Improper Access Control vulnerability","id":"CVE-2009-4762","kev_date_added":null,"published":"2010-03-29"},{"cvss_score":7.5,"headline":"MoinMoin improper sanitizes user profiles","id":"CVE-2010-0669","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":7.5,"headline":"MoinMoin has improper default configuration","id":"CVE-2010-0717","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration","id":"CVE-2010-0668","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin Access Restrictions Bypassed due to improper ACL enforcement","id":"CVE-2008-6603","kev_date_added":null,"published":"2009-04-03"},{"cvss_score":6.4,"headline":"MoinMoin Directory Traversal vulnerability","id":"CVE-2012-6080","kev_date_added":null,"published":"2013-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via segmentation fault in MoinMoin due to thread-unsafe password checking.","url":"https://insights.sbomify.com/CVE-2008-6549/"}