CVE-2008-6682 Apache Struts is vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML via improper handling of quotes and parameters in Apache Struts tags, requiring user interaction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2008-6682?
CVE-2008-6682 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 9 Apr 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.x before 2.0.11.1 and 2.1.x before 2.1.1 allow remote attackers to inject arbitrary web script or HTML via vectors associated with improper handling of (1) " (double quote) characters in the href attribute of an s:a tag and (2) parameters in the action attribute of an s:url tag.
Weakness: CWE-79
Which versions are affected by CVE-2008-6682?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.0.11.1 |
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.0.11.1 |
org.apache.struts:struts2-core Maven | From 2.1.0 | 2.1.1 |
org.apache.struts:struts2-core Maven | From 2.1.0 | 2.1.1 |
Products include Apache Struts.
How do I fix CVE-2008-6682?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.0.11.1 or 2.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2008-6682 being exploited?
There is no known exploitation of CVE-2008-6682 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-jgcr-9c2q-rvp8.