# CVE-2008-6682: Apache Struts is vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via improper handling of quotes and parameters in Apache Struts tags, requiring user interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-jgcr-9c2q-rvp8

## What is CVE-2008-6682?

CVE-2008-6682 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 9 Apr 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.x before 2.0.11.1 and 2.1.x before 2.1.1 allow remote attackers to inject arbitrary web script or HTML via vectors associated with improper handling of (1) " (double quote) characters in the href attribute of an s:a tag and (2) parameters in the action attribute of an s:url tag.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-6682?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.0.11.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.0.11.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.1.0 | 2.1.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.1.0 | 2.1.1 |

Products: Apache Struts.

## How do I fix CVE-2008-6682?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.0.11.1 or 2.1.1.

## Is CVE-2008-6682 being exploited?

There is no known exploitation of CVE-2008-6682 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-6682 and fix it if it is affected.

What it is: CVE-2008-6682 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 9 Apr 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-6682 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.0.11.1
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.0.11.1
- org.apache.struts:struts2-core (Maven): affected from 2.1.0; fixed in 2.1.1
- org.apache.struts:struts2-core (Maven): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-6682/ (Markdown: https://insights.sbomify.com/CVE-2008-6682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-6682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-6682
- OSV: https://osv.dev/vulnerability/CVE-2008-6682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-6682/
Summaries are generated and may contain mistakes; the official description above is the record.
