{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-6954 in the wild and no public exploit code.","fix":"Upgrade cobbler to 1.2.9 or later.","what":"CVE-2008-6954 is a critical vulnerability in n/a, published on 12 Aug 2009."},"fix_prompt":"Check this codebase for CVE-2008-6954 and fix it if it is affected.\n\nWhat it is: CVE-2008-6954 is a critical vulnerability in n/a, published on 12 Aug 2009. \nExploitation: There is no known exploitation of CVE-2008-6954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 1.2.9\n- cobbler (PyPI): affected all versions; fixed in 1.2.9\n- cobbler (PyPI): affected all versions; fixed in 1.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-6954/ (Markdown: https://insights.sbomify.com/CVE-2008-6954/index.md)","id":"CVE-2008-6954","markdown":"https://insights.sbomify.com/CVE-2008-6954/index.md","name":"CVE-2008-6954","record":{"aliases":["GHSA-p8w2-f44p-fmcj","PYSEC-2026-795"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"cobbler","vendor":"michael_dehaan"}],"cvss":{"score":9,"severity":"critical","source":"nvd","vector":"AV:N/AC:L/Au:S/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users to execute arbitrary Python code in cobblerd by editing a Cheetah kickstart template to import arbitrary Python modules.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability","id":"CVE-2008-6954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2008"},"n_packages":3,"n_references":8,"next":{"headline":"Information disclosure in n/a","id":"CVE-2008-6955"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-p8w2-f44p-fmcj"},{"ecosystem":"PyPI","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-p8w2-f44p-fmcj"},{"ecosystem":"PyPI","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-795"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2008-6953"},"products":["n/a"],"published":"2009-08-12","related":[{"cvss_score":8.5,"headline":"Cobbler is vulnerable to code injection","id":"CVE-2010-2235","kev_date_added":null,"published":"2010-12-09"},{"cvss_score":7.5,"headline":"Cobbler subject to Command Injection","id":"CVE-2012-2395","kev_date_added":null,"published":"2012-06-16"},{"cvss_score":7.5,"headline":"Hardcoded credentials in n/a","id":"CVE-2009-5021","kev_date_added":null,"published":"2010-12-09"},{"cvss_score":7.2,"headline":"Misconfiguration in n/a","id":"CVE-2010-4512","kev_date_added":null,"published":"2010-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2008-6954/"}