# CVE-2008-6954: Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability


- **Severity:** Critical 9.0 (`AV:N/AC:L/Au:S/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Aug 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-p8w2-f44p-fmcj, PYSEC-2026-795

## What is CVE-2008-6954?

CVE-2008-6954 is a critical vulnerability in n/a, published on 12 Aug 2009. 

### Official description

The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users to execute arbitrary Python code in cobblerd by editing a Cheetah kickstart template to import arbitrary Python modules.

Weakness: CWE-264

## Which versions are affected by CVE-2008-6954?

3 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 1.2.9 |
| `cobbler` | PyPI | All versions | 1.2.9 |
| `cobbler` | PyPI | All versions | 1.2.9 |

Products: Michael Dehaan Cobbler.

## How do I fix CVE-2008-6954?

Upgrade cobbler to 1.2.9 or later.

## Is CVE-2008-6954 being exploited?

There is no known exploitation of CVE-2008-6954 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-2235](https://insights.sbomify.com/CVE-2010-2235/): Cobbler is vulnerable to code injection (high 8.5)
- [CVE-2012-2395](https://insights.sbomify.com/CVE-2012-2395/): Cobbler subject to Command Injection (high 7.5)
- [CVE-2009-5021](https://insights.sbomify.com/CVE-2009-5021/): Hardcoded credentials in n/a (high 7.5)
- [CVE-2010-4512](https://insights.sbomify.com/CVE-2010-4512/): Misconfiguration in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-6954 and fix it if it is affected.

What it is: CVE-2008-6954 is a critical vulnerability in n/a, published on 12 Aug 2009. 
Exploitation: There is no known exploitation of CVE-2008-6954 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 1.2.9
- cobbler (PyPI): affected all versions; fixed in 1.2.9
- cobbler (PyPI): affected all versions; fixed in 1.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-6954/ (Markdown: https://insights.sbomify.com/CVE-2008-6954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-6954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-6954
- OSV: https://osv.dev/vulnerability/CVE-2008-6954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-6954/
Summaries are generated and may contain mistakes; the official description above is the record.
