CVE-2008-7248 Improper Input Validation in actionpack

Medium 6.8 Published Updated

Remote attackers can bypass CSRF protection in Ruby on Rails applications by exploiting token verification flaws for specific content types.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2008-7248?

CVE-2008-7248 is a medium-severity vulnerability in Rubyonrails Rails, published on 16 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Weakness: CWE-20

Which versions are affected by CVE-2008-7248?

4 open source packages ship an affected version, including actionpack. It affects 1 product.

PackageAffectedFixed in
actionpack RubyGemsFrom 2.1.02.1.3
actionpack RubyGemsFrom 2.1.02.1.3
actionpack RubyGemsFrom 2.2.02.2.2
actionpack RubyGemsFrom 2.2.02.2.2

Products include Rubyonrails Rails.

How do I fix CVE-2008-7248?

Upgrade actionpack to a fixed version for your release line: 2.1.3 or 2.2.2.

Is CVE-2008-7248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-7248 exists.

Public exploit code: 1 Exploit-DB entry.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2008-7248, GHSA-8fqx-7pv4-3jwm.

Is CVE-2008-7248 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free