# CVE-2008-7248: Improper Input Validation in actionpack

> Remote attackers can bypass CSRF protection in Ruby on Rails applications by exploiting token verification flaws for specific content types.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Dec 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2008-7248, GHSA-8fqx-7pv4-3jwm

## What is CVE-2008-7248?

CVE-2008-7248 is a medium-severity vulnerability in Rubyonrails Rails, published on 16 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2008-7248?

4 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.1.0 | 2.1.3 |
| `actionpack` | RubyGems | From 2.1.0 | 2.1.3 |
| `actionpack` | RubyGems | From 2.2.0 | 2.2.2 |
| `actionpack` | RubyGems | From 2.2.0 | 2.2.2 |

Products: Rubyonrails Rails.

## How do I fix CVE-2008-7248?

Upgrade actionpack to a fixed version for your release line: 2.1.3 or 2.2.2.

## Is CVE-2008-7248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-7248 exists.

Public exploit code:

- Ruby on Rails 2.3.5 - 'protect_from_forgery' Cross-Site Request Forgery (exploitdb)

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-7248 and fix it if it is affected.

What it is: CVE-2008-7248 is a medium-severity vulnerability in Rubyonrails Rails, published on 16 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-7248 exists.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.1.0; fixed in 2.1.3
- actionpack (RubyGems): affected from 2.1.0; fixed in 2.1.3
- actionpack (RubyGems): affected from 2.2.0; fixed in 2.2.2
- actionpack (RubyGems): affected from 2.2.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-7248/ (Markdown: https://insights.sbomify.com/CVE-2008-7248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-7248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-7248
- OSV: https://osv.dev/vulnerability/CVE-2008-7248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-7248/
Summaries are generated and may contain mistakes; the official description above is the record.
