CVE-2008-7252 phpMyAdmin unsafely handles temporary files
Critical 10.0
Published
Updated
Check this codebase for CVE-2008-7252 and fix it if it is affected.
What it is: CVE-2008-7252 is a critical vulnerability in Phpmyadmin Phpmyadmin, published on 19 Jan 2010.
Exploitation: There is no known exploitation of CVE-2008-7252 in the wild and no public exploit code.
Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 2.11.0; fixed in 2.11.10
- phpmyadmin/phpmyadmin (Packagist): affected from 2.11.0; fixed in 2.11.10
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2008-7252/ (Markdown: https://insights.sbomify.com/CVE-2008-7252/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2008-7252?
CVE-2008-7252 is a critical vulnerability in Phpmyadmin Phpmyadmin, published on 19 Jan 2010.
Official description
libraries/File.class.php in phpMyAdmin 2.11.x before 2.11.10 uses predictable filenames for temporary files, which has unknown impact and attack vectors.
Weakness: CWE-310
Which versions are affected by CVE-2008-7252?
2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.10 |
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.10 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2008-7252?
Upgrade phpmyadmin/phpmyadmin to 2.11.10 or later.
Is CVE-2008-7252 being exploited?
There is no known exploitation of CVE-2008-7252 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2008-7252, GHSA-9645-6g72-2pv8.