# CVE-2008-7263: Improper Authentication in pyftpdlib

> Remote attackers can bypass authentication via brute-force attacks due to missing response delays in the pyftpdlib FTP server library.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2010
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-q6w2-jxcm-2crj, PYSEC-2010-5

## What is CVE-2008-7263?

CVE-2008-7263 is a high-severity authentication bypass vulnerability in n/a, published on 19 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ftpserver.py in pyftpdlib before 0.5.0 does not delay its response after receiving an invalid login attempt, which makes it easier for remote attackers to obtain access via a brute-force attack.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2008-7263?

3 open source packages ship an affected version, including pyftpdlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |

Products: G.rodola Pyftpdlib.

## How do I fix CVE-2008-7263?

Upgrade pyftpdlib to 0.5.0 or later.

## Is CVE-2008-7263 being exploited?

There is no known exploitation of CVE-2008-7263 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-6737](https://insights.sbomify.com/CVE-2007-6737/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2007-6736](https://insights.sbomify.com/CVE-2007-6736/): Directory Traversal in pyftpdlib (medium 6.5)
- [CVE-2007-6741](https://insights.sbomify.com/CVE-2007-6741/): Improper privilege management in pyftpdlib (medium 6.5)
- [CVE-2008-7262](https://insights.sbomify.com/CVE-2008-7262/): Directory traversal in pyftpdlib (medium 6.5)
- [CVE-2007-6738](https://insights.sbomify.com/CVE-2007-6738/): pyftpdlib Use of Insufficiently Random Values of port selection on PASV command (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-7263 and fix it if it is affected.

What it is: CVE-2008-7263 is a high-severity authentication bypass vulnerability in n/a, published on 19 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-7263 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-7263/ (Markdown: https://insights.sbomify.com/CVE-2008-7263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-7263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-7263
- OSV: https://osv.dev/vulnerability/CVE-2008-7263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-7263/
Summaries are generated and may contain mistakes; the official description above is the record.
