# CVE-2008-7264: Improper input validation in pyftpdlib

> Remote authenticated users can cause a denial of service in pyftpdlib by sending a QUIT command during a disallowed data transfer.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2010
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-8p2c-fghc-9hj4, PYSEC-2010-6

## What is CVE-2008-7264?

CVE-2008-7264 is a medium-severity denial of service vulnerability in n/a, published on 19 Oct 2010. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The ftp_QUIT function in ftpserver.py in pyftpdlib before 0.5.0 allows remote authenticated users to cause a denial of service (file descriptor exhaustion and daemon outage) by sending a QUIT command during a disallowed data-transfer attempt.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2008-7264?

3 open source packages ship an affected version, including pyftpdlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |
| `pyftpdlib` | PyPI | All versions | 0.5.0 |

Products: G.rodola Pyftpdlib.

## How do I fix CVE-2008-7264?

Upgrade pyftpdlib to 0.5.0 or later.

## Is CVE-2008-7264 being exploited?

There is no known exploitation of CVE-2008-7264 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-6737](https://insights.sbomify.com/CVE-2007-6737/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2008-7263](https://insights.sbomify.com/CVE-2008-7263/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2007-6736](https://insights.sbomify.com/CVE-2007-6736/): Directory Traversal in pyftpdlib (medium 6.5)
- [CVE-2007-6741](https://insights.sbomify.com/CVE-2007-6741/): Improper privilege management in pyftpdlib (medium 6.5)
- [CVE-2008-7262](https://insights.sbomify.com/CVE-2008-7262/): Directory traversal in pyftpdlib (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-7264 and fix it if it is affected.

What it is: CVE-2008-7264 is a medium-severity denial of service vulnerability in n/a, published on 19 Oct 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-7264 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-7264/ (Markdown: https://insights.sbomify.com/CVE-2008-7264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-7264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-7264
- OSV: https://osv.dev/vulnerability/CVE-2008-7264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-7264/
Summaries are generated and may contain mistakes; the official description above is the record.
