# CVE-2008-7310: Spree does not properly restrict the use of a hash to provide values for a model's attributes

> Remote attackers can bypass payment steps and modify order states via mass assignment in Spree, requiring an upgrade to secure the application.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7h48-m3rw-vr27

## What is CVE-2008-7310?

CVE-2008-7310 is a medium-severity vulnerability in n/a, published on 4 Apr 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spree 0.2.0 does not properly restrict the use of a hash to provide values for a model's attributes, which allows remote attackers to set the Order state value and bypass the intended payment step via a modified URL, related to a "mass assignment" vulnerability.

Weakness: CWE-255

## Which versions are affected by CVE-2008-7310?

2 open source packages ship an affected version, including spree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree` | RubyGems | All versions | 0.4.0 |
| `spree` | RubyGems | All versions | 0.4.0 |

Products: Spreecommerce Spree.

## How do I fix CVE-2008-7310?

Upgrade spree to 0.4.0 or later.

## Is CVE-2008-7310 being exploited?

There is no known exploitation of CVE-2008-7310 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-7310 and fix it if it is affected.

What it is: CVE-2008-7310 is a medium-severity vulnerability in n/a, published on 4 Apr 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-7310 in the wild and no public exploit code.

Affected packages and fixed versions:
- spree (RubyGems): affected all versions; fixed in 0.4.0
- spree (RubyGems): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-7310/ (Markdown: https://insights.sbomify.com/CVE-2008-7310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-7310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-7310
- OSV: https://osv.dev/vulnerability/CVE-2008-7310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-7310/
Summaries are generated and may contain mistakes; the official description above is the record.
