{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.jackrabbit:jackrabbit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0026 exists.","fix":"Upgrade org.apache.jackrabbit:jackrabbit to 1.5.2 or later.","what":"CVE-2009-0026 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2009-0026 and fix it if it is affected.\n\nWhat it is: CVE-2009-0026 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0026 exists.\n\nAffected packages and fixed versions:\n- org.apache.jackrabbit:jackrabbit (Maven): affected all versions; fixed in 1.5.2\n- org.apache.jackrabbit:jackrabbit (Maven): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-0026/ (Markdown: https://insights.sbomify.com/CVE-2009-0026/index.md)","id":"CVE-2009-0026","markdown":"https://insights.sbomify.com/CVE-2009-0026/index.md","name":"CVE-2009-0026","record":{"aliases":["GHSA-6fxv-38xc-h866"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java content repository","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the q parameter in search.jsp or swr.jsp, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jackrabbit","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2009-01-20","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2009-01-20","kind":"exploitdb","ref":"32741","stars":null,"title":"Apache JackRabbit 1.4/1.5 Content Repository (JCR) - 'search.jsp?q' Cross-Site Scripting"},{"date":"2009-01-20","kind":"exploitdb","ref":"32742","stars":null,"title":"Apache JackRabbit 1.4/1.5 Content Repository (JCR) - 'swr.jsp?q' Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Jackrabbit contains Cross-site Scripting","id":"CVE-2009-0026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2009"},"n_packages":2,"n_references":8,"next":{"headline":"Path traversal in n/a","id":"CVE-2009-0027"},"packages":[{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit","purl":null,"source":"GHSA-6fxv-38xc-h866"},{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.jackrabbit:jackrabbit","purl":"pkg:maven/org.apache.jackrabbit/jackrabbit","source":"GHSA-6fxv-38xc-h866"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2009-0025"},"products":["n/a"],"published":"2009-01-21","related":[{"cvss_score":9.8,"headline":"Apache Jackrabbit RMI access can lead to RCE","id":"CVE-2023-37895","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":9.3,"headline":"Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens","id":"CVE-2026-92414","kev_date_added":null,"published":"2026-10-07"},{"cvss_score":8.8,"headline":"Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons","id":"CVE-2025-53689","kev_date_added":null,"published":"2025-07-14"},{"cvss_score":8.8,"headline":"Apache Jackrabbit Authentication Hijacking Vulnerability","id":"CVE-2016-6801","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":6.9,"headline":"Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies","id":"CVE-2026-92415","kev_date_added":null,"published":"2026-10-07"},{"cvss_score":6.5,"headline":"Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory","id":"CVE-2025-58782","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":6.4,"headline":"Improper Input Validation in Apache Jackrabbit","id":"CVE-2015-1833","kev_date_added":null,"published":"2015-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the q parameter in search.jsp or swr.jsp, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2009-0026/"}