{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.geronimo.plugins:console. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0038 exists.","fix":"Upgrade org.apache.geronimo.plugins:console to 2.1.4 or later.","what":"CVE-2009-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2009-0038 and fix it if it is affected.\n\nWhat it is: CVE-2009-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0038 exists.\n\nAffected packages and fixed versions:\n- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4\n- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-0038/ (Markdown: https://insights.sbomify.com/CVE-2009-0038/index.md)","id":"CVE-2009-0038","markdown":"https://insights.sbomify.com/CVE-2009-0038/index.md","name":"CVE-2009-0038","record":{"aliases":["GHSA-c372-x57p-6x7v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Geronimo Application Server","requires_auth":"high_privilege","summary":"Remote attackers can inject arbitrary web script or HTML into the Apache Geronimo web administration console, potentially compromising administrator sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"geronimo","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name, (2) ip, (3) username, or (4) description parameter to console/portal/Server/Monitoring; or (5) the PATH_INFO to the default URI under console/portal/.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2009-04-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2009-04-16","kind":"exploitdb","ref":"32920","stars":null,"title":"Apache Geronimo 2.1.x - '/console/portal/Server/Monitoring' Multiple Cross-Site Scripting Vulnerabilities"},{"date":"2009-04-16","kind":"exploitdb","ref":"32921","stars":null,"title":"Apache Geronimo 2.1.x - '/console/portal/' URI Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Geronimo Application Server multiple cross-site scripting (XSS) vulnerabilities","id":"CVE-2009-0038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2009"},"n_packages":2,"n_references":7,"next":{"headline":"Apache Geronimo Application Server CSRF vulnerabilities","id":"CVE-2009-0039"},"packages":[{"ecosystem":"Maven","fixed":["2.1.4"],"introduced":["2.1.0"],"last_affected":[],"package":"org.apache.geronimo.plugins:console","purl":null,"source":"GHSA-c372-x57p-6x7v"},{"ecosystem":"Maven","fixed":["2.1.4"],"introduced":["2.1.0"],"last_affected":[],"package":"org.apache.geronimo.plugins:console","purl":"pkg:maven/org.apache.geronimo.plugins/console","source":"GHSA-c372-x57p-6x7v"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2009-0037"},"products":["n/a"],"published":"2009-04-17","related":[{"cvss_score":10,"headline":"Apache Geronimo JMX Remoting functionality allows remote code execution in 3.x before v3.0.1","id":"CVE-2013-1777","kev_date_added":null,"published":"2013-07-11"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2007-4548","kev_date_added":null,"published":"2007-08-27"},{"cvss_score":9.4,"headline":"Apache Geronimo Application Server multiple directory traversal vulnerabilities","id":"CVE-2008-5518","kev_date_added":null,"published":"2009-04-17"},{"cvss_score":7.8,"headline":"Apache Geronimo Hash Collisions Cause DoS","id":"CVE-2011-5034","kev_date_added":null,"published":"2011-12-30"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2007-5797","kev_date_added":null,"published":"2007-11-03"},{"cvss_score":6.8,"headline":"Apache Geronimo Application Server CSRF vulnerabilities","id":"CVE-2009-0039","kev_date_added":null,"published":"2009-04-17"},{"cvss_score":5,"headline":"Auth bypass in n/a","id":"CVE-2007-5085","kev_date_added":null,"published":"2007-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into the Apache Geronimo web administration console, potentially compromising administrator sessions.","url":"https://insights.sbomify.com/CVE-2009-0038/"}