# CVE-2009-0038: Apache Geronimo Application Server multiple cross-site scripting (XSS) vulnerabilities

> Remote attackers can inject arbitrary web script or HTML into the Apache Geronimo web administration console, potentially compromising administrator sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Apr 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-c372-x57p-6x7v

## What is CVE-2009-0038?

CVE-2009-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name, (2) ip, (3) username, or (4) description parameter to console/portal/Server/Monitoring; or (5) the PATH_INFO to the default URI under console/portal/.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-0038?

2 open source packages ship an affected version, including org.apache.geronimo.plugins:console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geronimo.plugins:console` | Maven | From 2.1.0 | 2.1.4 |
| `org.apache.geronimo.plugins:console` | Maven | From 2.1.0 | 2.1.4 |

Products: Apache Geronimo.

## How do I fix CVE-2009-0038?

Upgrade org.apache.geronimo.plugins:console to 2.1.4 or later.

## Is CVE-2009-0038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0038 exists.

Public exploit code:

- Apache Geronimo 2.1.x - '/console/portal/Server/Monitoring' Multiple Cross-Site Scripting Vulnerabilities (exploitdb)
- Apache Geronimo 2.1.x - '/console/portal/' URI Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2013-1777](https://insights.sbomify.com/CVE-2013-1777/): Apache Geronimo JMX Remoting functionality allows remote code execution in 3.x before v3.0.1 (critical 10.0)
- [CVE-2007-4548](https://insights.sbomify.com/CVE-2007-4548/): Auth bypass in n/a (critical 10.0)
- [CVE-2008-5518](https://insights.sbomify.com/CVE-2008-5518/): Apache Geronimo Application Server multiple directory traversal vulnerabilities (critical 9.4)
- [CVE-2011-5034](https://insights.sbomify.com/CVE-2011-5034/): Apache Geronimo Hash Collisions Cause DoS (high 7.8)
- [CVE-2007-5797](https://insights.sbomify.com/CVE-2007-5797/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0038 and fix it if it is affected.

What it is: CVE-2009-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Apr 2009. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0038 exists.

Affected packages and fixed versions:
- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4
- org.apache.geronimo.plugins:console (Maven): affected from 2.1.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0038/ (Markdown: https://insights.sbomify.com/CVE-2009-0038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0038
- OSV: https://osv.dev/vulnerability/CVE-2009-0038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0038/
Summaries are generated and may contain mistakes; the official description above is the record.
