# CVE-2009-0258: Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection

> Remote attackers can execute arbitrary commands via crafted filenames in the TYPO3 indexed_search extension due to improper handling of shell metacharacters.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-74w6-ww7w-45j9

## What is CVE-2009-0258?

CVE-2009-0258 is a critical command injection vulnerability in Typo3 Typo3, published on 22 Jan 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Indexed Search Engine (indexed_search) system extension in TYPO3 4.0.0 through 4.0.9, 4.1.0 through 4.1.7, and 4.2.0 through 4.2.3 allows remote attackers to execute arbitrary commands via a crafted filename containing shell metacharacters, which is not properly handled by the command-line indexer.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2009-0258?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.0.0 | 4.0.10 |
| `typo3/cms` | Packagist | From 4.0.0 | 4.0.10 |
| `typo3/cms` | Packagist | From 4.1.0 | 4.1.8 |
| `typo3/cms` | Packagist | From 4.1.0 | 4.1.8 |
| `typo3/cms` | Packagist | From 4.2.0 | 4.2.4 |
| `typo3/cms` | Packagist | From 4.2.0 | 4.2.4 |

Products: Typo3 Typo3.

## How do I fix CVE-2009-0258?

Upgrade typo3/cms to a fixed version for your release line: 4.0.10, 4.1.8 or 4.2.4.

## Is CVE-2009-0258 being exploited?

There is no known exploitation of CVE-2009-0258 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)
- [CVE-2020-15098](https://insights.sbomify.com/CVE-2020-15098/): Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0258 and fix it if it is affected.

What it is: CVE-2009-0258 is a critical command injection vulnerability in Typo3 Typo3, published on 22 Jan 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-0258 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.0.0; fixed in 4.0.10
- typo3/cms (Packagist): affected from 4.0.0; fixed in 4.0.10
- typo3/cms (Packagist): affected from 4.1.0; fixed in 4.1.8
- typo3/cms (Packagist): affected from 4.1.0; fixed in 4.1.8
- typo3/cms (Packagist): affected from 4.2.0; fixed in 4.2.4
- typo3/cms (Packagist): affected from 4.2.0; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0258/ (Markdown: https://insights.sbomify.com/CVE-2009-0258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0258
- OSV: https://osv.dev/vulnerability/CVE-2009-0258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0258/
Summaries are generated and may contain mistakes; the official description above is the record.
