# CVE-2009-0260: MoinMoin Multiple cross-site scripting (XSS) vulnerabilities

> Remote attackers can inject arbitrary web script or HTML via the AttachFile action in MoinMoin Wiki, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-7hjm-hqgj-xv9f, PYSEC-2026-670

## What is CVE-2009-0260?

CVE-2009-0260 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin before 1.8.1 allow remote attackers to inject arbitrary web script or HTML via an AttachFile action to the WikiSandBox component with (1) the rename parameter or (2) the drawing parameter (aka the basename variable).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-0260?

3 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.8.1 |
| `moin` | PyPI | All versions | 1.8.1 |
| `moin` | PyPI | All versions | 1.8.1 |

Products: Moinmoin Moinmoin.

## How do I fix CVE-2009-0260?

Upgrade moin to 1.8.1 or later.

## Is CVE-2009-0260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0260 exists.

Public exploit code:

- MoinMoin 1.8 - 'AttachFile.py' Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2004-1463](https://insights.sbomify.com/CVE-2004-1463/): MoinMoin Improper Privilege Management (critical 10.0)
- [CVE-2004-1462](https://insights.sbomify.com/CVE-2004-1462/): MoinMoin Improper Access Control (high 7.5)
- [CVE-2004-0708](https://insights.sbomify.com/CVE-2004-0708/): MoinMoin allows administrative access (high 7.5)
- [CVE-2008-1937](https://insights.sbomify.com/CVE-2008-1937/): MoinMoin vulnerable to privilege escalation (medium 6.8)
- [CVE-2007-2423](https://insights.sbomify.com/CVE-2007-2423/): Cross-site scripting in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0260 and fix it if it is affected.

What it is: CVE-2009-0260 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0260 exists.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.8.1
- moin (PyPI): affected all versions; fixed in 1.8.1
- moin (PyPI): affected all versions; fixed in 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0260/ (Markdown: https://insights.sbomify.com/CVE-2009-0260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0260
- OSV: https://osv.dev/vulnerability/CVE-2009-0260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0260/
Summaries are generated and may contain mistakes; the official description above is the record.
