CVE-2009-0580 Exposure of Sensitive Information in Apache Tomcat
Remote attackers can enumerate valid usernames in Apache Tomcat when FORM authentication is enabled, due to improper error handling in specific authentication realms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2009-0580?
CVE-2009-0580 is a medium-severity vulnerability in Apache Tomcat, published on 5 Jun 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attackers to enumerate valid usernames via requests to /j_security_check with malformed URL encoding of passwords, related to improper error checking in the (1) MemoryRealm, (2) DataSourceRealm, and (3) JDBCRealm authentication realms, as demonstrated by a % (percent) value for the j_password parameter.
Weakness: CWE-200
Which versions are affected by CVE-2009-0580?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.40 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.40 |
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.5.28 |
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.5.28 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.19 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.19 |
Products include Apache Tomcat.
How do I fix CVE-2009-0580?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.40, 5.5.28 or 6.0.19.
Is CVE-2009-0580 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-0580 exists.
Public exploit code: 1 Metasploit module and 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-w227-xcfx-3pj8.