{"answers":{"affected":"4 open source packages ship an affected version, including products-plonepas, Products.PlonePAS and plone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-0662 in the wild and no public exploit code.","fix":"Upgrade products-plonepas to 3.9 or later.","what":"CVE-2009-0662 is a medium-severity authentication bypass vulnerability in n/a, published on 23 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2009-0662 and fix it if it is affected.\n\nWhat it is: CVE-2009-0662 is a medium-severity authentication bypass vulnerability in n/a, published on 23 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2009-0662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- products-plonepas (PyPI): affected from 3; fixed in 3.9\n- products-plonepas (PyPI): affected from 3; fixed in 3.9\n- Products.PlonePAS (PyPI): affected from 3; fixed in 3.9\n- plone (PyPI): affected from 3.0 up to 3.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-0662/ (Markdown: https://insights.sbomify.com/CVE-2009-0662/index.md)","id":"CVE-2009-0662","markdown":"https://insights.sbomify.com/CVE-2009-0662/index.md","name":"CVE-2009-0662","record":{"aliases":["GHSA-pq3x-96c3-xgjg","PYSEC-2009-17","PYSEC-2026-739"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Plone CMS plugin","requires_auth":"low_privilege","summary":"Authenticated users can impersonate arbitrary users in PlonePAS due to improper login form handling, leading to privilege escalation.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plonepas","vendor":"plone"}],"cvss":{"score":6,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:S/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The PlonePAS product 3.x before 3.9 and 3.2.x before 3.2.2, a product for Plone, does not properly handle the login form, which allows remote authenticated users to acquire the identity of an arbitrary user via unspecified vectors.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects Products.PlonePAS","id":"CVE-2009-0662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2009"},"n_packages":4,"n_references":5,"next":{"headline":"Memory corruption in n/a","id":"CVE-2009-0663"},"packages":[{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["3"],"last_affected":[],"package":"Products.PlonePAS","purl":null,"source":"GHSA-pq3x-96c3-xgjg"},{"ecosystem":"PyPI","fixed":[],"introduced":["3.0"],"last_affected":["3.1","3.2","3.3","3.4","3.5"],"package":"plone","purl":"pkg:pypi/plone","source":"PYSEC-2009-17"},{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["3"],"last_affected":[],"package":"products-plonepas","purl":"pkg:pypi/products-plonepas","source":"GHSA-pq3x-96c3-xgjg"},{"ecosystem":"PyPI","fixed":["3.9"],"introduced":["3"],"last_affected":[],"package":"products-plonepas","purl":"pkg:pypi/products-plonepas","source":"PYSEC-2026-739"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2009-0661"},"products":["n/a"],"published":"2009-04-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Authenticated users can impersonate arbitrary users in PlonePAS due to improper login form handling, leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2009-0662/"}